Ошибка при обновлении Rake через Bundle

Ошибка при обновлении Rake через Bundle
Столкнулся с проблемой версионности Rake и как следствие получил вот такую ошибку.

rake aborted!
Gem::LoadError: You have already activated rake 10.3.2, but your Gemfile requires rake 10.1.1. Prepending `bundle exec` to your command may solve this.


Все вроде бы просто — нужно выполнить:

# bundle exec

Но тут проблема:

-bash: bundle: command not found

Решение: нужно добавить путь к ruby gems в PATH. Делается это следующей командой:

# export PATH=$PATH:/var/lib/gems/1.9.1/bin/

После этого запускаем

# bundle update rake

Готово. Rake обновлен до нужной версии.

Stas Kuryan

Web developer. Перфекционист в написании кода.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *